STEM help / Editor skills

4.2.3 Opening a model

If you want to open a model which does not appear on the recent-files list:

  1. Select Open from the File menu. This displays the Open Model dialog.
  2. Select the drive and directory where the model file is stored.
  3. Type in the name of the file, e.g., mobile (STEM automatically adds a .dtl file extension), or select a name from the list.

Note: You can open several models at once by making a multiple selection from the list of files.

The recent-files list on the File menu gives quick access to models recently opened or saved from the Editor. The number of files listed can be set between 0 and 9 using the Recent Files List… option on the Options menu.

The Recent Files List dialog

Windows Explorer

STEM models can be viewed and edited directly from Windows Explorer. The required association of the .dtl model file extension is done automatically by the STEM installation program and the Editor will load additional models if it is already running. The following file types are registered and associated with the STEM Model Editor and Results program as appropriate.

File type Extension Application
STEM model .dtl STEM Model Editor
STEM compiled model .dtm
STEM model layout .icp
STEM model results .smr STEM Results program
STEM results workspace .smw

Registered STEM file types

In addition, when the model data is loaded or checked, a file called mobile.err is used to store references to any errors.

Multi-user file locking

When a model is open in the Editor, STEM locks the file in order to prevent inadvertent parallel editing by another user. If a model is being edited by user A, and then user B attempts to open the same model file; then user B will be warned that the model is already being edited by user A, and will be given the option to open the model ‘read-only’, i.e., in a state where any subsequent modifications must be saved with a new filename.

Note: The .dtl and .dtm input files must be shared with the other STEM processes when a model is run, so the Editor actually locks – and monitors existing locks on – a separate lock file, with the same name as the model but with extension.lock.

 

       Buy SSL

© Implied Logic Limited