STEM help / Model structure

9.3.4 Varying fields independently

Associating a number of input parameters with a single dimension allows you to define a coherent range of values for each of those values. For every variant value for the first parameter, there is a corresponding value for each of the other inputs. However, there may be instances when it is desirable to vary one parameter independently from another, e.g., to consider a number of different scenarios for resource Capital Cost which are not directly correlated with the scenarios you may have defined for service Demand.

Adding another dimension

There are two different approaches to introducing a new dimension to the scenarios in a model, the simplest being to start from the new input you want to vary:

  1. Select Costs from the resource icon menu. The resource Costs dialog is displayed.
  2. Use the mouse or cursor keys to select the Capital Cost field.
  3. Enter a working value, say 100.
  4. Now select Add as Scenario Parameter… from the Variants menu on the Costs dialog. The Choose Dimension for New Parameter dialog is displayed, with the choice of an existing dimension or a new one.
  5. Now select <new Dimension> and click OK. A new dimension element is created, and the Editor prompts for the name of this element if Automatic Names is not checked in the main Options menu.
  6. Enter the name Cost and press <Enter>, selecting Rename from the icon menu if necessary. Several new variant elements for this dimension are also created, so that you can enter a range of values straightaway, and the Variant Data dialog is displayed, with one column for each new variant. The first parameter is automatically identified as the Capital Cost field, and the original value of 100 is copied into the corresponding field for each variant. The working field is shaded pink to indicate that it is now a scenario parameter.
  7. If Automatic Names is checked in the main Options menu, you can select Rename Element… from the Edit menu in the Variant Data dialog to enter the names Low, Medium and High for each column in turn.
  8. Enter 90 for the Low variant and 110 for the High variant.

Note: resource Capital Cost is a scalar field, rather than a time series, so there is no point entering anything other than a constant for these variants, as STEM will always use the year-zero values when applying these data.

Figure 1: Adding another dimension

Alternatively, you may prefer to structure the scenarios from the toolbar first:

  1. Click the Dimension button on the toolbar or press <Ctrl+Shift+D> to create a new dimension element. STEM will prompt for the name of this element if Automatic Names is not checked in the main Options menu.
  2. Enter the name Cost and press <Enter>, selecting Rename from the icon menu if necessary.
  3. Click the Variant button on the toolbar or press <Ctrl+Shift+V> to create three new variant elements, with the names Low, Medium and High.
  4. Proceed as from step 4 above, selecting Cost from the Choose Dimension for New Parameter dialog.

You can choose whichever of these two approaches feels more intuitive for creating a new dimension.

Running multi-dimensional scenarios from the Editor

When you define variants in just one dimension, you can think of these variants synonymously with the actual scenarios that you can run. However, when you define variants in several dimensions, the number of potential scenarios grows rather rapidly, equal to the number of possible combinations of one variant from each eimension. For example, with variants Pessimistic, Probable and Optimistic in a Demand dimension and variants Low, Medium and High in a Cost dimension, there are nine possible scenarios, from Pessimistic/Low through to Optimistic/High.

However, rather than considering all these combinations, it is more likely that you would want to focus on certain ‘slices’ through the scenario space, perhaps varying Demand against the Medium Cost variant, and varying Cost against the Probable Demand variant. You would certainly want to be able to avoid running every possible scenario!

Low Medium High
Pessimistic û ü û
Probable ü ü ü
Optimistic û ü û

Figure 2: Slices through a two-dimensional scenario space

The Editor presents the set of possible scenarios of a STEM model in a list in the Scenarios and Sensitivities dialog, and you can make a ‘flat’ selection from this list in order to identify which scenarios you are interested in, the remainder of which can be excluded from the run process:

  1. Select Scenarios and Sensitivities… from the File menu on the main window. The Scenarios and Sensitivities dialog is displayed for the model, with the nine possible combinations of the six variants listed under the heading Demand/Cost.
  2. Select the scenarios indicated in the table above, holding down the <Ctrl> key to make the non-contiguous selection with the mouse.

Figure 3: Selecting scenarios to run

Note: You can also access the Scenarios and Sensitivities dialog by selecting List from the Variants menu on a normal data dialog or a Variant Data dialog. The Scenarios and Sensitivities dialog may be re-sized in order to distinguish the names of scenarios where the use of multiple dimension elements causes the scenario names to exceed the width of the list box.

  1. Click the Selection button to run the five selected scenarios. The model is first saved, and you will see that the button heading changes from Save and Run to just Run. The alternative data from each dimension are then applied in turn to generate the five scenarios, which are then checked, run and sorted as normal.

Note: When you are developing scenarios of a model, it may not be clear initially which slices to focus on; in which case you can click the All button to run every combination, and then ponder the selection in the Results program. If you are experimenting with different working values for some parameters, check the Include Working Model box to run the working model with the scenarios when you click the Selection or All buttons.

Comparing multi-dimensional scenarios in the Results program

When scenarios of a multi-dimensional model are run, the dimension/variant structure is used to generate the inputs for the selected scenarios, prior to running. From STEM 7.5 onwards, once the scenarios have been run, the available scenario results can be presented either in a single linear list in the Results program, rather like the Scenarios dialog in the Editor (see also Linear selection), or in a new dimensional view. Both are described below:

Linear selection of scenarios
  1. Select Draw… from the Graphs menu in the Results program. The Draw dialog is displayed.
  2. Select Resource 1 in the Elements tab and add it to the Selected list.
  3. In the Graphs tab, select Capital Expenditure.
  4. Move to the Scenarios tab. If Linear Selection is checked, the scenarios you have just run will be displayed in a single flat Available list. If you also select the Include Out-of-Date Scenarios checkbox (unchecked by default), it will allow you to select these out-of-date scenarios for inclusion in a results graph at such time as they are updated (out-of-date scenarios are denoted by square brackets).

Figure 4: Linear Selection of scenarios, with out-of-date scenarios also shown

  1. Uncheck the Include Out-of-Date scenarios checkbox, and add the five scenarios listed to the Available list. The scenarios will all be drawn on a single graph unless you select the Separate Graphs option. Press OK to draw the graph.

Figure 5: Selection of up-to-date scenarios to draw on a graph

  1. The selected graph is displayed, with one line for each scenario.

Figure 6: Comparing scenarios in the Results program

If you are reviewing large numbers of scenario results, it may be impractical to plot them all on a single traditional time-series line graph. In such cases, it may be clearer to create a ‘snapshot’ of all the results at a particular point in time, such as at the end of the model run. This is achieved by selecting Snapshot from the Draw Graphs dialog – see Permalink ‘04060000’ not found.

Dimensional selection of scenarios

A new dimensional view introduced in STEM 7.5 made it more straightforward to choose scenarios, particularly if there are several dimensions in a model – see also Dimensional selection.

  1. As for linear selection of scenarios, select Draw… from the Graphs menu in the Results program. The Draw dialog is displayed.
  2. Select Resource 1 in the Elements tab and add it to the Selected list.
  3. In the Graphs tab, select Capital Expenditure.
  4. In the Scenarios tab, ensure that Linear Selection is not checked. A dimensional view is displayed, in which the working model is shown first and then each variant is listed by dimension, even for scenarios which have not been run and are out-of-date.

Figure 7: The dimensional view, in which variants are listed by dimension

  1. If you don’t select any variants from this list, then the resulting graph will show the results for the working model only (if results are up-to-date). If you select a variant from one dimension and add it to the Selected list, then you are selecting everything that goes with it: for example, if you select High from Cost, then Pessimistic/High, Probable/High and Optimistic/High are shown in a linear Selected list (out-of-date scenarios shown in square brackets).

Figure 8: Selection of the single variant High results in selection of all /High-associated variants

  1. Alternatively, if you select specific elements from separate dimensions (e.g., Probable from the Demand dimension and High from Cost, then only the relevant Probable/High combination will be in the Selected list.

Figure 9: Selection of specific elements from separate dimensions

  1. Once you have selected the scenarios of interest, press OK to draw them on a graph.

Removing a dimension

If you decide that one of the dimensions in a model is no longer of interest, the Editor provides a number of ways to delete it directly (when you are sure you have applied the right variant values to the working model):

  • select the dimension icon and press <Del> or select Delete… from the Edit menu on the main window
  • select Delete from the Dimension icon menu.

The Editor prompts to confirm this action. On confirmation, any inputs identified by this dimension cease to be scenario parameters, and any variants associated with this dimension are deleted, along with the corresponding variant data.

As each variant is deleted, the number of potential scenarios falls; but the removal of the last variant in a dimension has no impact on the number of scenarios, only their names, and the final removal of the dimension has no direct effect at all. Thus a dimension is effectively removed from the scenario space when its last variant is deleted.

For example, with variants Pessimistic, Probable and Optimistic in a Demand dimension and variants Low, Medium and High in a Cost dimension, there are nine possible scenarios, from Pessimistic/Low through to Optimistic/High (as shown in Figure 2 above). If the Cost dimension is deleted, first of all the variants are removed: without High, there are six scenarios left, from Pessimistic/Low through to Optimistic/Medium; then without Medium, there are just three, from Pessimistic/Low through to Optimistic/Low; and then without Low, there are still three scenarios, but now the names are just Pessimistic through to Optimistic. The final removal of the Cost dimension element itself has no further impact.

 

       Buy SSL

© Implied Logic Limited