STEM help / Model structure

9.5.3 Defining variants for replication

When a parameter is added to a template, STEM automatically creates up to three variants if there were none previously. In order to create additional variants:

  1. Left-click to select the template icon.
  2. Click the Variant button on the toolbar and then click again in the view window (or press <Ctrl+Shift+V>). A new variant is created, linked to the template.

Note: Alternatively, you can select any variant in the template before clicking the Variant button. This eases the consecutive creation of several variants.

You can also insert a new variant directly into the template Variant Data table:

  1. Select Variant Data from the template icon menu. The Variant Data tabular dialog is displayed.
  2. Select the desired column.
  3. Select Insert Element from the tabular dialog Edit menu. A new variant is created and inserted before the current column.

Note: Press <Shift> while selecting Insert to insert after the current column.

Deleting instances

In order to remove an individual variant:

  1. Right-click to select the icon and then press <Delete>, or
  2. Select Delete from the variant icon menu, or
  3. Select Remove Element from the Variant Data tabular dialog menu.
 

       Buy SSL

© Implied Logic Limited