STEM help / Editor skills

4.1.2 Essential STEM Editor concepts

The STEM Editor allows you to construct a picture of the telecoms network or fragment that you want to model. Each element within the network – e.g., service demand and the resources to satisfy that demand – is created from the toolbar and then represented as an icon in a view window.

Each element has a number of associated dialogs, accessed from a pop-up menu on the icon, which allow you to enter and review data for that element. Dialogs for data which affects the whole model (global data) are accessed from the main Data menu or from a pop-up menu on the view window. From this information, the demand, installed capacities, costs and revenues associated with the model are calculated for each year of the model run.

Relationships and dependencies between model elements can be defined directly by dragging between the corresponding icons. These links are then indicated by different coloured lines between the icons. In addition to these automatic links, you can add manual links to illustrate relationships outside the model.

The Save and Run command in the File menu first saves the current model data and layout, before checking the data for consistency and then running the model. If there are any errors, these are displayed directly in the Editor and you can use Next Error from the File menu to step through any other errors; otherwise the model results will be automatically loaded into the STEM Results program.

 

       Buy SSL

© Implied Logic Limited