STEM help / Editor skills

4.5.6 Accessing tabular dialogs

As well as the data dialogs associated with each individual element, it is possible to compare the data for several elements of the same type side-by-side in a tabular dialog.

A multiple selection of elements

If you want to make a quick, side-by-side comparison of the data for a number of elements of the same type, e.g., Capital Cost Structure for a number of Resources, you can create a tabular dialog from the icon menu for any one of a multiple selection of Resource elements:

  1. Select the Resources you are interested in by rubber-banding, or by holding down the <Shift> key and clicking on the corresponding icons.
  2. Right-click on any of those icons to access the usual Resource icon menu.

Note: If you prefer, you can double-click on the icon instead, but you must keep the <Shift> key pressed; otherwise the first click will cancel the selection!

  1. Select Capital Cost Structure from the Advanced menu. A tabular Capital Cost Structure dialog is displayed with a column for each Resource in the selection.

Capital Cost Structure dialog for a selection of Resources

You can insert, remove and rename elements in such a table, but the selection table is a temporary structure created for your convenience. If you want to edit a certain group of elements together on a regular basis you should create a Collection – see 9.2.1 Creating a Collection of elements.

Note: Once a table has been created for a selection, it retains no link with the selection in the view. Selecting other icons will not affect the table, nor will inserting elements in the table affect the selection of icons. Although you can insert elements directly into the table, the quickest way to generate a table for a new selection of icons is simply to select it from the icon menu.

Note: Unlike tables for Collections, it is not possible to use the dialog Move menu to access tables for related data from a table for a selection.

Note: You can use the button in any table for a Market Segment, Collection or selection to access the standard table showing the corresponding data for all elements of the given type – see All elements of a single type below.

A hybrid selection of elements

When you make a multiple selection of icons, the menu for any one of those icons will be just the same as the menu for an individual icon, if all of the corresponding elements are of the same type, e.g., a selection of Resources.

In general, if you select a number of elements of different types, the icon menu is reduced to the common actions, such as copying, renaming, etc., because there is no data common to the different types of element.

However, if you select a number of elements and also Collections of elements of the same type, the icon menu includes all the usual element data items; in the same way that a hybrid Collection (containing elements and Collections of elements of the same type) can be used to compare data for each of the elements in the nested Collections. Only the Collection Elements item is omitted from the menu.

As you would expect, since Market Segments can be thought of as Collections of Services, the same is true for a selection of Services and Market Segments, where the common icon menu includes all the usual Service data items, omitting the extra options for individual Market Segments.

Thus you can use any multiple selection of elements, Collections of elements and even Collections of Collections of elements (of the same type) to make a quick side-by-side comparison of the corresponding data.

All elements of a single type

Sometimes it can be useful to view all elements of the same type side-by-side, both to compare the respective data and also to examine any dependencies between them.

All the standard data dialogs for individual elements can be viewed as tables:

  • select Tables from the Data menu, or
  • click on the button in an individual element dialog, or
  • check the Tables from Icons item on the Options menu to access tabular dialogs directly from individual icon menus.

The usual data are presented, with one column for each element of the same type, and can be edited just as in an individual element dialog. The Edit menu in a tabular dialog allows you to insert, rename or delete elements directly in the table.

You can also view dependencies between elements in a single-column table:

  • select Demand or Supply from the Data menu and choose the type of element, or
  • select Defaults from an individual icon menu.

The table has one row for each element of the given type, presented as a button which leads to the data for that element. If you have used drag-and-drop to paste a link between two icons, the dependency will be shown as a simple-reference formula for the dependent element, showing that the first element provides default values for the second. You can review such a formula in this table and also use drag-and-drop between buttons to create similar links. For more details, see 4.13.3 Finding and removing external links and 4.15 Copying and pasting data.

 

       Buy SSL

© Implied Logic Limited